Provider Issue (Equinix Connect)

Incident Report for Equinix

Resolved

The power issue has been mitigated, and full redundancy was restored. All services and power systems were fully operational as of 11:25 UTC. The IBX Operations team is currently preparing a detailed Root Cause Analysis (RFO).
Incident Number: INC0110336
[Equinix Connect - ZH]
Posted Nov 05, 2025 - 15:54 UTC

Update

The power issue has been mitigated, and full redundancy was restored. All services and power systems were fully operational as of 11:25 UTC. The IBX Operations team is currently preparing a detailed Root Cause Analysis (RFO).
Incident Number: INC0110336
[Equinix Connect - ZH]
Posted Nov 05, 2025 - 13:09 UTC

Identified

Equinix SMC detected a power issue in ZH5 IBX at 10:12 UTC. Equinix engineers are evaluating the situation and will provide more details as they become available.
Incident Number: INC0110336
[Equinix Connect - ZH]
Posted Nov 05, 2025 - 11:24 UTC